Web Hosting Forum | Lunarpages

Author Topic: When I upload pictures .. it do not show !! ?  (Read 66557 times)

Offline dado

  • Space Explorer
  • ***
  • Posts: 7
When I upload pictures .. it do not show !! ?
« on: June 28, 2011, 12:21:22 PM »
Hello
 First, I apologize for my weak English

I have create a subdomain
I want to design a Website on it
And has already designed and I want to upload it now

But when I wanted to upload the images folder
Images do not show!!

[ The webpage cannot be found


HTTP 404


Most likely causes:
•There might be a typing error in the address.
•If you clicked on a link, it may be out of date. ]

What is the problem?
Is there any one can help me solve this problem?


Offline wektech

  • Master Jedi
  • *****
  • Posts: 1032
    • Yuma Arizona Information
Re: When I upload pictures .. it do not show !! ?
« Reply #1 on: June 28, 2011, 05:13:13 PM »
Give us the url's so we can look and see what is wrong.

Offline dado

  • Space Explorer
  • ***
  • Posts: 7
Re: When I upload pictures .. it do not show !! ?
« Reply #2 on: June 28, 2011, 07:15:22 PM »
this is the url for the image
http://video.lazio4arab.com/images/bg.jpg

and this is the subdomain
http://video.lazio4arab.com/

I open a ticket in lunarpages and this is what tell me .. maybe this is useful
Quote
[Tue Jun 28 01:04:17 2011] [error] [client 95.19.3.162] File does not exist: /home/×××/public_html/video/404.shtml
[Tue Jun 28 01:04:17 2011] [error] [client 95.19.3.162] File does not exist: /home/×××/public_html/video/home/×××/public_html/redir.php



I hope that I find the solution from you
 Because my site is down now on this problem

thanks

Offline wektech

  • Master Jedi
  • *****
  • Posts: 1032
    • Yuma Arizona Information
Re: When I upload pictures .. it do not show !! ?
« Reply #3 on: June 29, 2011, 03:28:40 AM »
There seems to be some sort of redirect going on. Is it possible that you have enabled hotlink protection and redirected to a non-existant file names redir.php?

Offline dado

  • Space Explorer
  • ***
  • Posts: 7
Re: When I upload pictures .. it do not show !! ?
« Reply #4 on: June 29, 2011, 07:49:41 AM »

Hello wektech
 Thank you for your interest

 In fact I do not know what the problem is
 And I do not have a file name of redir.php

 What is the way to see what happens
 And solve this problem?

 When I upload pages such as index.html , menu.html and other pages
 the  pages show naturally

 But when I upload an image  it does not show

How to solve this problem
 Please help me

Offline wektech

  • Master Jedi
  • *****
  • Posts: 1032
    • Yuma Arizona Information
Re: When I upload pictures .. it do not show !! ?
« Reply #5 on: June 29, 2011, 08:56:16 AM »
You need to check in your cpanel or LPCP to see if hotlink protection is turned on. If so disable it to see if that is the problem.

Offline dado

  • Space Explorer
  • ***
  • Posts: 7
Re: When I upload pictures .. it do not show !! ?
« Reply #6 on: June 29, 2011, 10:11:56 AM »
HotLink protection is currently disabled
I tried to change it for the experiment only

and this message appears to me

Quote
There was an error while enabling hotlink protection
Apache detected an error in the Rewrite config. Syntax error on line 37 of /home/×××/public_html/.htaccess.c40LKEOUQXk9lRSu1rqQOaynMWoSk3q8:
Missing  directive at end-of-file
 Please try again.

I hope that's useful to see the problem and its solution

Offline wektech

  • Master Jedi
  • *****
  • Posts: 1032
    • Yuma Arizona Information
Re: When I upload pictures .. it do not show !! ?
« Reply #7 on: June 30, 2011, 10:45:02 AM »
ca you copy and paste the contents of your .htaccess file

Offline dado

  • Space Explorer
  • ***
  • Posts: 7
Re: When I upload pictures .. it do not show !! ?
« Reply #8 on: June 30, 2011, 11:35:39 AM »
Quote
RewriteEngine On
AddDefaultCharset Off


####Gzip
<IfModule mod_rewrite.c>
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^(.*)(js|css|gif|jpg)$ redir.php?file=$1$2&type=$2 [L]
</IfModule>

####ETags
FileETag None

####Expires
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/gif A2592000
ExpiresByType image/jpeg A2592000
ExpiresByType image/png A2592000
ExpiresByType application/x-shockwave-flash A2592000
ExpiresByType text/css A2592000
ExpiresByType application/x-javascript A2592000
</IfModule>

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

Offline dado

  • Space Explorer
  • ***
  • Posts: 7
Re: When I upload pictures .. it do not show !! ?
« Reply #9 on: July 01, 2011, 09:01:28 PM »
wektech where are you my friend ??

Offline wektech

  • Master Jedi
  • *****
  • Posts: 1032
    • Yuma Arizona Information
Re: When I upload pictures .. it do not show !! ?
« Reply #10 on: July 02, 2011, 04:02:08 AM »
I would remove the following code from your .htaccess to see if everything will work

Code: [Select]
####Gzip
<IfModule mod_rewrite.c>
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^(.*)(js|css|gif|jpg)$ redir.php?file=$1$2&type=$2 [L]
</IfModule>

Offline dado

  • Space Explorer
  • ***
  • Posts: 7
Re: When I upload pictures .. it do not show !! ?
« Reply #11 on: July 03, 2011, 01:10:56 AM »
Thank you my friend.
 The problem was resolved

Offline wektech

  • Master Jedi
  • *****
  • Posts: 1032
    • Yuma Arizona Information
Re: When I upload pictures .. it do not show !! ?
« Reply #12 on: July 03, 2011, 06:35:48 AM »
For what this worth, the code seems to be from a product called vbseo, a plugin for vbulletin. If you are still using vbulletin, you should ensure all is still working after the change.

 

Share |