Web Hosting Forum | Lunarpages

Author Topic: Rather Surprised that Lunar Pages is still using SMF 2.0.11  (Read 6557 times)

Offline LunarpagesClient

  • Newbie
  • *
  • Posts: 3
Rather Surprised that Lunar Pages is still using SMF 2.0.11
« on: September 22, 2017, 07:16:07 AM »


Greetings:


I have been using the SMF software for over a decade. I started with probably  1.0.11

The current production version is SMF 2.0.14, which they have reworked almost totally. I had to rebuild my site from the ground up, and somehow the release of SMF 2.0.14 coincided with that, so I simply scrapped the old site totally and started afresh. Been almost 6 months and haven't had a single issue. 

Is there some special reason Lunar Pages still uses 2.0.11


Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6235
Re: Rather Surprised that Lunar Pages is still using SMF 2.0.11
« Reply #1 on: September 22, 2017, 08:31:27 AM »
I couldn't tell you why they are three releases behind. I did remind them of this several months ago, but I don't know what their schedule is (I'm not on the side of the fence that takes care of these things). Perhaps it's a low priority, and as long as it doesn't break, they want to leave well enough alone. I don't think they've had any significant problems with 2.0.11. I expect to eventually see them upgrade to 2.0.14+. I wouldn't expect a jump to 2.1 any time soon, unless PHP 7 doesn't work with 2.0.

I don't mind keeping my SMF at the latest level (2.0.14), and have had no problems with the one-button upgrade, even though I have half a dozen mods installed and a dozen or so custom code changes (including putting the last DB error timestamp in a separate file, so Settings.php never gets mangled, and member-selectable timezone rather than just an hours offset). Of course, I take a file and DB backup first, in case anything goes wrong.
Visit My Site

E-mail Me
  
-= From the ashes shall rise a sooty tern =-

 

Share |