Web Hosting Forum | Lunarpages

Author Topic: Cannot Access WordPress Media Library  (Read 1640 times)

Offline stewpixie

  • Trekkie
  • **
  • Posts: 11
Cannot Access WordPress Media Library
« on: August 24, 2016, 09:16:04 AM »
I am currently using a themeforest template called Kalium (I installed the latest version of the theme today). I created svg files and uploaded to the Media Library (two weeks ago). When I try to attach an image from the Media Library to my pages I just see a small sphere just turning and turning and nothing happens. I canít import images from the Media Library. I have the following errors in my Media Library for svg files:
Warning: simplexml_load_file(): http://in8designs.com/wp-content/uploads/2016/08/hibicus-1.svg:129876: parser error : AttValue length too long in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1138
Warning: simplexml_load_file(): 8x+zkA8ALg/rX0Jw0wiwAukjZu7HAMAKmEPhWsUCgHC2Y+sxpN8TnO9JAHS7APWrhwsBanGQ/Ahl in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1138
Warning: simplexml_load_file(): ^ in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1138
Warning: simplexml_load_file(): http://in8designs.com/wp-content/uploads/2016/08/hibicus-1.svg:129876: parser error : Memory allocation failed in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1138
Warning: simplexml_load_file(): http://in8designs.com/wp-content/uploads/2016/08/hibicus-1.svg:129921: parser error : xmlSAX2Characters: huge text node in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1138
Warning: simplexml_load_file(): <image overflow="visible" width="3828" height="2652" id="Layer_0_xA0_Image" xlin in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1138
Warning: simplexml_load_file(): http://in8designs.com/wp-content/uploads/2016/08/hibicus-1.svg:129921: parser error : Extra content at the end of the document in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1138
Fatal error: Call to a member function attributes() on boolean in /home/tamar5/public_html/wp-content/themes/kalium/inc/laborator_filters.php on line 1140
Any help to solve this problem is kindly appreciated. Thanks.
« Last Edit: September 02, 2016, 08:20:56 AM by MrPhil »

Offline stewpixie

  • Trekkie
  • **
  • Posts: 11
Re: Cannot Access WordPress Media Library
« Reply #1 on: August 25, 2016, 07:25:12 AM »
I was able to figure out why I couldn't connect with the Media Library (caused by Scalable Vector Graphics plugin). But I still can't figure out the cause of the errors that appear in the Media Library. The errors seems to be caused by this line:

$image = array( $image[0], $width, $height )

I guess it's a pretty straightforward line but I am not sure what this variable means when it is calling up the images. Thanks.

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6188
Re: Cannot Access WordPress Media Library
« Reply #2 on: September 02, 2016, 08:15:28 AM »
I'm not surprised that line of code could be causing problems. It's creating an array named $image out of the first element of $image (probably the file name) and the width and height. I'm suspicious that it's re-creating the $image variable in the same expression that uses it as input. While technically legal, it looks rather odd, and perhaps in some versions of PHP it could cause problems, especially if at least one of the values is missing. Is your server at PHP 5.6?

Not being familiar with WordPress, I really can't take it any further than that. You might want to get on to a WP discussion forum and ask for guidance there (also with the SVG problem).

Does your hibicus-1.svg file display properly in a browser, all by itself?
« Last Edit: September 02, 2016, 08:21:11 AM by MrPhil »
Visit My Site

E-mail Me
  
-= From the ashes shall rise a sooty tern =-

 

Share |