Web Hosting Forum | Lunarpages

Author Topic: Softtaculous Zenbership install failure  (Read 8033 times)

Offline obsydi2

  • Galactic Royalty
  • *****
  • Posts: 364
    • http://www.obsydian.com
Softtaculous Zenbership install failure
« on: December 10, 2017, 09:19:13 PM »
When I attempt to install Zenbership via Softaculous I'm greeted with the "Could not access your domain. Please make sure your domain is pointing to this server and there is no .htaccess file restricing access to your domain" (sic) error message.

I temporarily removed the existing .htaccess file from my public_html directory. I replaced my index.html file that was redirecting to an old, non-existent joomla directory so that it just displays a "hi there" message.

Anyone familiar with this error and possible conditions that could cause it?

Relevant install details:
 o Protocol: http://www
 o Domain: obsydian.com
 o Directory: <new directory>
« Last Edit: December 10, 2017, 09:27:36 PM by obsydi2 »

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6246
Re: Softtaculous Zenbership install failure
« Reply #1 on: December 11, 2017, 08:48:54 AM »
OK, so your .htaccess (if any) is not rewriting or redirecting anywhere, and the only index file is a simple "Hi there"? Make sure you've cleaned out all traces of your old Joomla installation, in case there's any redirects/rewrites (SEO stuff) still around. This would include stuff like
Code: [Select]
RewriteCond  %{REQUEST_FILE}  !-f
RewriteCond  %{REQUEST_FILE}  !-d
in case you're not too familiar with .htaccess coding.

There are a couple things that might give you that message:
  • You have non-standard directory permissions. I think public_html is usually 750 and any subsidiary directories are 755.
  • The installation is expecting that you manually create that new directory before trying to install into it (and it doesn't exist yet), or even that it wants to create this directory and you already made it. Read the instructions carefully to see which it's expecting, and if not clear, try it both ways.
Visit My Site

E-mail Me
  
-= From the ashes shall rise a sooty tern =-

Offline obsydi2

  • Galactic Royalty
  • *****
  • Posts: 364
    • http://www.obsydian.com
Re: Softtaculous Zenbership install failure
« Reply #2 on: December 11, 2017, 10:07:25 AM »
Thanks for the comments.

Installation instructions are clear that the new directory should not exist... and it doesn't. The old Joomla directory was deleted long before I attempted this installation and all traces are gone except the old index file that was still redirecting to it (note: this is a personal site and I've not been using it for a public web presence for a couple of years). I'll review permissions this evening. Other tidbits from around the web suggest that this is a common problem because of Softaculous's use of cURL for installing packages. I wish they'd push the actual error message to the top of the stack so I'd know what was actually happening.

If I don't find something obvious with the permissions angle, I'll open development tools and start tracing things.

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6246
Re: Softtaculous Zenbership install failure
« Reply #3 on: December 11, 2017, 03:02:28 PM »
One of the very first things it should then be trying to do is create the directory. Did this succeed? I would also be leery of this thing trying to chmod it to 777, which is a no-no on Lunarpages (suPHP is running). It will be able to chmod, but then any further actions in that directory are dead meat (500 error). It's possible that LP has not tried every Softaculous package installation.

If you can't get anywhere, think about getting the Zenbership install package from their site (I presume it's available) and doing a manual install. At least, you can look inside their install script and see what it's trying to do. I don't trust "one button" installers, be they Softaculous or any other brand. cURL usage can also be a problem, but if Softaculous always uses it, then presumably it's properly configured for LP. Any sign of where it's trying to remotely run on, or what it's trying to do with cURL?
Visit My Site

E-mail Me
  
-= From the ashes shall rise a sooty tern =-

Offline obsydi2

  • Galactic Royalty
  • *****
  • Posts: 364
    • http://www.obsydian.com
Re: Softtaculous Zenbership install failure
« Reply #4 on: December 11, 2017, 08:46:23 PM »
Sadly the manual installation was a bust. For now, at least. Turns out the application requires magic quotes to be turned off and they are on for the rhea server config. The installer won't proceed until they are off. There are further steps I can take to run a local php.ini configuration, but it's more work than I want to get into this evening. My initial attempt was losing PDO support.

I was attempting to debug the javascript but I'm working from a Mac laptop this evening. I'm not familiar with debugging tools for Safari and was trying to use Chrome on a Mac. I don't trust the Developer Tools in Chrome on a Mac. I'm not convinced they work in that environment. Chrome can be a bit flaky on a Mac without delving into tools at that level. I might tackle it again from one of my Windows machines in a couple of days.

It's quite possible that the magic quotes requirement was being kicked back to the Softaculous installer and the result was the error message I reported earlier; that might be their catch-all error.

Oh, and looking at the Zenbership code would not yield any answers about the original error. The cURL comments were about Softaculous code being used to perform the installation. I won't see any of that looking at the Zenbership code.
« Last Edit: December 11, 2017, 08:49:17 PM by obsydi2 »

Offline obsydi2

  • Galactic Royalty
  • *****
  • Posts: 364
    • http://www.obsydian.com
Re: Softtaculous Zenbership install failure
« Reply #5 on: December 27, 2017, 07:46:19 PM »
An update. Lunar upgraded/migrated my server, Rhea, yesterday. I ran the Softaculous installer for Zenbership and installed without so much as a wimper.

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6246
Re: Softtaculous Zenbership install failure
« Reply #6 on: December 28, 2017, 06:37:36 AM »
OK, chalk this one up to server problems (or incompatibilities) then. Good to hear you're up and running now.
Visit My Site

E-mail Me
  
-= From the ashes shall rise a sooty tern =-

 

Share |