Lunarpages Web Hosting Forum

Author Topic: 3rd party scripts forced upgrades  (Read 458 times)

Offline greylin

  • Spacescooter Operator
  • *****
  • Posts: 37
  • Here on behalf of a small Scottish charity
3rd party scripts forced upgrades
« on: June 02, 2018, 02:46:29 AM »
A few days ago I guess I was not alone in receiving this from Lunarpages:

Quote
This email is regarding the outdated installation of certain PHP scripts you have installed on your account. For security reasons you must update these outdated installations as soon as possible. In the event that they are not updated within 5 business days, they will be automatically updated. Please keep in mind that if your scripts are automatically updated, you will run the risk of something on your site breaking.
 
We strongly recommend making backups of your site’s content and any custom settings you may have. If you do not create your own backup, you run the risk of having to recreate content or your entire website. However, in the event that you do not have your own backups, our system keeps backups for 3-5 days. Please understand that we will not restore your account to any date prior to the updates made. Any accessible backups will be zipped up and made available to you to download locally. We will not allow any rollbacks or restores to previous versions. These backups can be accessed through our Managed Shared Hosting program if you need them.
 
The following script updates are available:
 
MediaWiki 1.30.0

phpBB 3.2.2

My immediate concern is for my two MediaWiki installations, both of which are v1.29. These are going to be compulsorily updated to v1.30. I have already tried the update myself and it fails every time because FileInfo needs to be enabled. I have talked to the support team about this and they steadfastly maintain that FileInfo will not be enabled on shared servers (such as Elara) because it will take up too many resources.  They also suggested that I keep a local copy of a backup - but, of course, if MediaWiki 1.30 doesn't work there will be nowhere to restore it to, so duh.

Bottom line is, when the upgrade goes ahead, my two wikis will stop working so I would like to stay at 1.29 until either Lunarpages can work something out re FileInfo, or I can come up with an alternative plan. Preferably the former, but if I have to move to another hosting company I would like the time to do some research first and will also need to work out how to export (not just back up) my wikis, which isn't at all straightforward.





Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6340
Re: 3rd party scripts forced upgrades
« Reply #1 on: June 02, 2018, 04:47:30 AM »
Additional discussion: https://www.lunarforums.com/index.php?topic=100522.0

If the latest edition of MediaWiki requires system resources (FileInfo) that LP has withdrawn, that sounds like a big problem. Even a fresh installation wouldn't work, then, would it? All I can suggest in this case is that you escalate the issue to management and make sure they understand that they're encouraging/forcing the installation of an application that can't be run.

Even if they didn't force an upgrade, would MediaWiki 1.29 break because FileInfo is going away, or is FileInfo use introduced with 1.30?
Visit My Site

E-mail Me
-= From the ashes shall rise a sooty tern =-

Offline greylin

  • Spacescooter Operator
  • *****
  • Posts: 37
  • Here on behalf of a small Scottish charity
Re: 3rd party scripts forced upgrades
« Reply #2 on: June 02, 2018, 05:38:36 AM »
The need for FileInfo was introduced with MediaWiki 1.30 and LP don't want to enable it on shared servers. Previous versions have never required it which is why they still work.

How does one escalate to management?  I did click the link asking for escalation to a supervisor in my ticket discussion but all that happened was that the support guy said he had spoken to his supervisor who suggested reporting the issue to feedback@lunarpages.com - which I did, but there's been no response.

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6340
Re: 3rd party scripts forced upgrades
« Reply #3 on: June 02, 2018, 07:12:15 AM »
There's also the Feedback and Review board on this forum, but beyond that, I don't know of any other formal avenues. Maybe you can PM some of the administrators on this forum, as they may have some connections (but don't be annoying about it). Look around at lunarpages.com and see if there are any contact methods there.

LP really needs to deal with WikiMedia's new requirement for FileInfo that's going to break all WikiMedia installations.
Visit My Site

E-mail Me
-= From the ashes shall rise a sooty tern =-

Offline greylin

  • Spacescooter Operator
  • *****
  • Posts: 37
  • Here on behalf of a small Scottish charity
Re: 3rd party scripts forced upgrades
« Reply #4 on: June 02, 2018, 07:54:53 AM »
Thank you very much.

Offline greylin

  • Spacescooter Operator
  • *****
  • Posts: 37
  • Here on behalf of a small Scottish charity
Re: 3rd party scripts forced upgrades
« Reply #5 on: June 03, 2018, 07:23:18 AM »
Well, this morning I received a nice surprise, a very positive message from one of the supervisors who is passing my case on to the server admins. I'm not out of the woods yet but feeling more hopeful.

Offline MrPhil

  • Senior Moderator
  • Berserker Poster
  • *****
  • Posts: 6340
Re: 3rd party scripts forced upgrades
« Reply #6 on: June 03, 2018, 12:14:42 PM »
That's good news. Sometimes a wheel that squeaks a bit can get some grease! With regards to MediaWiki, I think LP has two choices:
  • Stop at MW 1.29 and do not support (or require) higher versions until FileInfo requirement is removed.
  • Support FileInfo so that MW 1.30 will work. That still leaves you having to monitor the upgrade (or do it yourself), but at least  it should be possible now.
Visit My Site

E-mail Me
-= From the ashes shall rise a sooty tern =-